[Resolvido] Não está aplicando desconto da fatura no boleto

Marcado: , ,

Este tópico contém respostas, possui 2 vozes e foi atualizado pela última vez por  Cristian Roberto da Luz 2 anos, 6 meses atrás.

  • Autor
    Posts
  • #9149

    Boa noite!

    Estou com o módulo boleto Versão 0.2.7, PHP 7 e o WHMCS última versão (acho que é 7.1).

    Uma compra foi realizada aplicando um cupom de desconto, e a fatura foi gerada com desconto da forma que mostra neste print: http://prnt.sc/epacej

    Entretanto, o boleto não considerou o valor do desconto e gerou com valor cheio: http://prnt.sc/epabu5

  • #9150

    Meu caro, enviei em privado o debug da api.. abraço!

  • #9168

    Segue dados da api:

    https://pastebin.com/YyJAs2hb

  • #9179

    Gofas
    Participante

    Gratidão por compartilhar o diagnóstico!

    No debug está tudo ok, acredito que você tenha misturado arquivos de versões diferentes do módulo na sua instalação, faça o seguinte:
    apague todos os arquivos do módulo do seu WHMCS, suba a versão mais recente e depois acesse as configurações e clique em “Salvar”.

  • #9201

    Boa tarde!

    Removi e reinstalei o módulo, não funcionou :-\.

    Segue abaixo fatura com logs da api e boleto gerado…
    http://webmind.com.br/gofas-desconto.pdf

    http://webmind.com.br/gofas-boleto.pdf

  • #9243

    Gofas
    Participante

    Tente excluir as transações associadas à fatura e acessa-la novamente, é provável que o Boleto que vc está vendo foi gerado antes de plicar o desconto.

  • #9257

    Boa tarde,

    Eu criei manualmente uma fatura, com a inserção do desconto na mesma ordem da criação automática de uma compra com cupom de desconto whmcs. Gravei todo o processo e upei, pra facilitar:

    https://youtu.be/3E4wz_pkCrM

    O retorno da API eu coloquei aqui:

    https://pastebin.com/ySNtw4ag

  • #9259

    Gofas
    Participante

    Oi Cristian, você fez um ótimo trabalho para coletar as informações, gratidão mais uma vez!

    Descobrimos a causa do erro, é um bug que ocorreu na transição da versão 0.2.5 para 0.2.6 do módulo, ocasionada por um bug temporário no Github, que inclusive foi um dos motivos que influenciou na nossa decisão de hospedar os repositórios de download dos módulos nos nossos próprios servidores.

    Pode ficar tranquilo que até segunda feira teremos corrigido isso, lhe aviso logo que subir a atualização =)

  • #9261

    Ótimo! Eu que agradeço novamente a presteza que tem feito pela comunidade. Abraço e Feliz Páscoa! =)

Você deve fazer login para responder a este tópico.