Ir para o conteúdo

Boleto não gerado para usuários novos cadastrados

Marcado: 

  • Este tópico contém 7 respostas, 7 vozes e foi atualizado pela última vez 8 meses, 3 semanas atrás por João Paulo de A. Rodrigues.
Visualizando 7 respostas da discussão
  • Autor
    Posts
    • #12581
      Andre
      Participante

      Versão do WHMCS: 7.9.2
      Versão do PHP: 7.1.33

      Saudações!

      Notamos que os boletos gerados para usuários já cadastrados previamente cadastrados no sistema antes da última atualização não sofreram alterações. Inclusive em caso de adição de novos serviços. Porém, para clientes recentemente cadastrados, o boleto não é gerado.

      Alguém obteve o mesmo comportamento?

      Grato pelo auxílio!

    • #12736
      Gofas
      Mestre

      Andre,
      o erro deve estar acontecendo por que mudou a forma de obter os dados cadastrais,
      por favor, acesse este formulário e nos envie o log de uma fatura com erro para vermos quais campos não estão sendo passados para a API Gerencianet:
      https://gofas.net/contato/?suporte=Ajuda%20/%20Suporte

    • #12754
      Fábio
      Participante

      Percebi este erro também.
      O Erro exibido na Fatura:
      “Erro: 3500034, validation_error, Array”

    • #12757
      Gofas
      Mestre

      @fabio-seabra, para um diagnóstico mais eficiente, precisamos ver o log ou debug completo desse erro, que mostra todas as informações do WHMCS processadas para envio à API.
      Por favor, siga os passos a seguir para obter o log de depuração:

      1) Acesse no painel administrativo do WHMCS, Opções > Pagamento > Portais para Pagamento > Manage Existing Gateways > Gofas Gerencianet - Boleto;

      2) Ative a opção 6- Modo Diagnóstico / Debug para obter o debug diretamente na tela da fatura;

      3) Ative a opção 7- Salvar Logs para salvar as informações de diagnóstico em Utilitários > Logs > Log de Módulo.
      Para funcionar, antes é necessário ativar o debug de módulo clicando em “Ativar Log de Debug” na página Utilitários > Logs > Log de Módulo;

      4) Reproduza o erro, copie todo o debug na fatura, ou os dados do _request_ e _response_ em Utilitários > Logs > Log de Módulo. Com os dados em mãos, use o novo formulário de suporte para enviar os dados de depuração, é seguro e totalmente confidencial:
      https://gofas.net/contato/?suporte=Ajuda%20/%20Suporte

    • #12820
      thiago
      Participante

      o meu estava com o mesmo problema (Erro: 3500034, validation_error, Array), eu corrigi pois descobri que era o telefone errado que estava no cadastro do meu cliente.

    • #12991
      Rafael Angelo
      Participante

      lá, poderiam me ajudar ?
      Encontrei o mesmo problema em dois modulos, tanto juno quanto gerencianet para este erro, e identifiquei que em ambos apresenta uma falha na colocação da / ao final do domínio.

      [metadata] => Array
      (
      [custom_id] => 43964
      [notification_url] => https://dominio.comcloud//modules/gateways/gofasgerencianetboleto/includes/callback.php
      )

      Note que https://dominio.comcloud//modules … apresenta uma falta de / entre .com e cloud e impoe duas // após cloud, onde cloud é minha pasta admin renomeada.
      Fiz testes com a pasta admin em seu nome padrão e o erro permanece o mesmo.

      Tive este mesmo problema no Juno e deixei de usar, implantei o gerencianet, nos testes funcionou, mas ao sinal de primeira fatura em produção deu erro.

    • #12969
      Samuel Alves de Souza
      Participante

      Estou com o mesmo erro, foi definido como consertar?

    • #12889
      João Paulo de A. Rodrigues
      Participante

      O erro acontece por não ter um um formato de telefone válido cadastrado… Pelo menos foi o que aconteceu comigo.

Visualizando 7 respostas da discussão
  • Você deve fazer login para responder a este tópico.
Role para cima